404 error on newly uploaded apps


So about two weeks ago I uploaded an app to my Lampix and everything worked fine.
Though today I tried to do the same, I uploaded another app, though the app showed a 404 page.

Both times I uploaded a .zip with a index.html and package.json.

Also when accessing the app through the app switcher it says the name of the app is the same as the name of the .zip that I uploaded. So it seems that it doesn’t read my package.json to get the name of the app.

What could be the cause of this?
And what should my steps be to debug this?

Thanks in advance.


Could you please post here the contents of your ‘package.json’ file?
Also, does the .zip file have the same file structure as it had two weeks ago, when you successfully uploaded the app?

It would help if you could provide the .zip as was uploaded to my.lampix.com. You’re describing what seems to be an issue with the archive (since index.html was not found, and package.json could not be read).

EDIT: Feel free to send a private message if you want to keep the contents of the .zip file private.

So it turned out that my zip was wrongly compiled.
I needed to make a zip of the files, instead of a zip of the directory these file are in.

Thanks @dbalaban for the help :slight_smile:

1 Like

Glad we could help, @boaz!