Application examples do not work

I downloaded some application examples that you offer with the developer pack, however when I run them on the Lampix simulator, I realize that they don’t work as expected. With the example of the application with fruits, the simulator only loads me the HTML page and I have the impression that the page index.js (containing all the functions necessary for the detection of the movements, etc) didn’t use …
Can you help me ?

Hi @Mathieu,

I just tried out example-fruits and it seems to be working as expected.

Off the top of my head, there are two things I can suggest:

  1. Make sure you followed the installation steps in the example-fruits repository (in short, to install the dependencies and start the application in development mode).
  2. After loading the app in the simulator, select a watcher name and class for that simulation, and then click inside either the NeuralNetworkClassifier or MovementBasedSegmenter areas (based on what you chose; the areas are marked with a white border, each with its name above it).

Here’s an example of the selection mentioned in point 2):

If you’re still seeing issues, click on the devtools button (as seen in the screenshot above) to open the debugging interface and let us know if there are any assets that fail to load or what errors you’re seeing.

Furthermore, if you could provide the steps you followed from the cloning of the repository to opening the app in the simulator, it would help a great deal in resolving this.


I am aware of the installation steps, however, they are done on Linux no? I did it in another way. I simply downloaded the zip file via the site “” and put it under a folder named “fruits” after exporting it.

Do I have to order in Linux? If yes, how ?
I already tried, and that gave me an error at the step “npm start”, the following:

npm ERR! Windows_NT 6.1.7601
npm ERR! argv “C:\Program Files\nodejs\\node.exe” “C:\Program Files\nodejs\node_modules\npm\bin\npm-cli.js” “start”
npm ERR! node v0.12.3
npm ERR! npm v3.10.6
npm ERR! [email protected] start: webpack-dev-server -d --inline --hot --config internals/
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] start script ‘webpack-dev-server -d --inline --hot --config internals/’.
npm ERR! Make sure you have the latest version of node.js and npm installed.
npm ERR! If you do, this is most likely a problem with the example-fruits package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR! webpack-dev-server -d --inline --hot --config internals/
npm ERR! You can get information on how to open an issue for this project with:
npm ERR! npm bugs example-fruits
npm ERR! Or if that isn’t available, you can get their info via:
npm ERR! npm owner ls example-fruits
npm ERR! There is likely additional logging output above.

npm ERR! Please include the following file with any support request:
npm ERR! C:\Users\mathieu.leguyadec\Documents\Fruits\ProjetFruits\example-fruits\npm-debug.log

Do you have a solution for this error? Or, is there another solution?

The issue you’re seeing is related to the old version version of Node you’re using (v0.12). Since it’s Webpack that’s first to complain, I checked its minimum requirement, and that’s v6.11.5 (as seen here).

Regarding the installation steps, they are the same on any operating system that supports Node.

To help you out, I’ve included the example-fruits v1.0.0 build in the repository. Download it again, and load the index.html file in the simulator.

Let me know how it goes.

I just downloaded the v6.11.5 version of Node.js as shown in detail in nodejs .exe file under: C:\Program Files (x86)\nodejs

File version :

But when I execute the command “npm install” it gives me the same error as above … He tells me that it’s still the version: v0.12.3
Do you have a solution to this problem?

Thank you for your help.

You need to uninstall the old version. I recommend uninstalling them both, and using a node version manager for Windows (nvm-windows. Then use the node version manager to install and use any Node version you require whenever you need it.

This would allow you to have multiple Node versions at the same time, whereas installing them by downloading from the official site does not.


I removed nodejs as you told me and I just downloaded nvm-windows but where should I place it on the computer, under “Program Files (x86)” or under “example-fruits”?

Currently, I put it under “Program Files (x86)”

But when I execute the command “nvm install 6.11.5” the command displays an error:

“nvm: The term “nvm” is not recognized as a cmdlet name, function, script file, or program
executable. Check the spelling of the name, or if a path exists, check that the path is
correct and try again.”

And to execute this command, where should I do it? Right now I’m using Visual Studio 2017 and its terminal window. I don’t know if it’s the good solution …

Provided you installed nvm-windows, the installation directory of your choosing (Program Files (x86)) is fine. It shouldn’t be inside an application.

Seems like there’s a bit of an issue regarding your operating system and the support nvm-windows offers. Read more.

If you’re alright with having only one version of Node running, then I recommend installing 10.15.0 from (the button on the left).

As for where to run the command, any terminal that has access to Node & NPM (Visual Studio 2017’s terminal should be fine) is viable. Run commands in the root directory of the application you’re interested in affecting (in this case, example-fruits).


I installed nvm-window successfully this time, I finally have a good version of node. So I went to the npm install step via the command “npm install” because before I didn’t have the folder “nodes_modules” in my project “example-fruits”.

After the installation of npm, it sends me back this error, which from what I see, is related to the lack of Python under the disk (C :slight_smile:

gyp ERR! configure error
gyp ERR! stack Error: Can’t find Python executable “python”, you can set the PYTHON env variable.
gyp ERR! stack at PythonFinder.failNoPython (C:\Users\ID3I\Documents\ProjetFruits\Projet_Fruits\example-fruits\node_modules\node-gyp\lib\configure.js:484:19)
gyp ERR! stack at PythonFinder. (C:\Users\ID3I\Documents\ProjetFruits\Projet_Fruits\example-fruits\node_modules\node-gyp\lib\configure.js:509:16)
gyp ERR! stack at C:\Users\ID3I\Documents\ProjetFruits\Projet_Fruits\example-fruits\node_modules\graceful-fs\polyfills.js:284:29
gyp ERR! stack at FSReqWrap.oncomplete (fs.js:154:21)
gyp ERR! System Windows_NT 10.0.17134
gyp ERR! command “C:\Program Files\nodejs-nvm\node.exe” “C:\Users\ID3I\Documents\ProjetFruits\Projet_Fruits\example-fruits\node_modules\node-gyp\bin\node-gyp.js” “rebuild” “–verbose” “–libsass_ext=” “–libsass_cflags=” “–libsass_ldflags=” “–libsass_library=”
gyp ERR! cwd C:\Users\ID3I\Documents\ProjetFruits\Projet_Fruits\example-fruits\node_modules\node-sass
gyp ERR! node -v v10.15.0
gyp ERR! node-gyp -v v3.8.0
gyp ERR! not ok
Build failed with error code: 1
npm WARN [email protected] No repository field.
npm WARN optional SKIPPING OPTIONAL DEPENDENCY: [email protected] (node_modules\fsevents):
npm WARN notsup SKIPPING OPTIONAL DEPENDENCY: Unsupported platform for [email protected]: wanted {“os”:“darwin”,“arch”:“any”} (current: {“os”:“win32”,“arch”:“x64”})

Do I have to install it?

Thanks for your help :slight_smile:

And I add to that, still some small npm error…
npm ERR! errno 1
npm ERR! [email protected] postinstall: node scripts/build.js
npm ERR! Exit status 1
npm ERR!
npm ERR! Failed at the [email protected] postinstall script.
npm ERR! This is probably not a problem with npm. There is likely additional logging output above.

npm ERR! A complete log of this run can be found in:
npm ERR! C:\Users\ID3I\AppData\Roaming\npm-cache_logs\2019-01-22T08_42_47_821Z-debug.log

node-gyp (a dependency of some of the npm modules used) uses Python. You don’t need to install node-gyp yourself, but do need to set things up for node-gyp. In order to do that, see option 1 of setting node-gyp up.

Afterwards, remove the node_modules folder and try installing again.

Everything works well with nodejs, I’m in the deployment stage on the Lampix and I’m stuck at the stage where it is necessary to put the IP address of my Lampix to access the web page http://<ip>:8888/apps . In fact, I have the message “this site can not be reached”.

However when I made the command “ifconfig” on the command prompt of Lampix, I got the IP address of it.

Do you have something to solve this problem?

Suppose Lampix’s IP is
Wait for an application (such as the app switcher) to start. You can take this as a confirmation that Lampix’s webserver is up and running. The URL you should go to is then

The following should be met:

  1. Replace the fictitious IP above with the one you got from Lampix.
  2. Ensure Lampix and the device you’re trying to access the website from are on the same network.

In fact I wonder if the web server of Lampix works I did what was said in the deployment steps. But when I run the application on Lampix, it only displays the contents of index.html, I find it weird…

Futhermore, the URL http://localhost:8080 works and displays what should be displayed on the Lampix…

Can you confirm that any other app works? Such as the default ones on Lampix: app-switcher, rainy-sounds, trivia.

Trivia works, it was the only one available on Lampix when first used.

And when I’m on the application selector it says “(local)” under “Fruits example”

If any application works, then the webserver works.

Since we’ve crossed out the important steps in how to deploy an app: are you trying to get the application to recognize fruits? If yes, then you may have missed an important warning, and regarding

only displays the contents of index.html

I misinterpreted and didn’t consider that you were trying to actually use the application with Lampix (thinking you simply wanted to learn how to deploy it). My apologies.

If you want to upload an app that is ready to be used with Lampix, go for rainy-sounds.

I just saw that the application of fruit could not run on the Lampix itself … Excuse me too …
I will try with rainy in this case. Thank you for your help.

No problem. I’m glad we took this opportunity to setup your development environment.

Let me know how the installation of rainy-sounds goes.